Jetbrains Idea 2019.3.5 不能识别GOROOT SDK版本的解决办法
咻兔哔 / 资源分享

Jetbrains Idea 2019.3.5 不能识别GOROOT SDK版本的解决办法

本子太老了,安装新的Idea 太卡,而且由于大家懂得的原因,越来越难, 2019.3 够用而且 还算轻量,就打算继续使用,但是碰到了GOROOT无法识别的问题!

解决方法:

  1. 进入go sdk的src/runtime/internal/sys目录

  2. 编辑zversion.go文件

// Code generated by go tool dist; DO NOT EDIT.
package sys

const StackGuardMultiplierDefault = 1
const theVersion = `go1.17`

将go1.17替换成现在的版本

参考资料:

  • https://blog.csdn.net/u011243684/article/details/123865556

  • https://youtrack.jetbrains.com/issue/GO-11588#focus=Comments-27-5127829.0-0

此问题在IDEA 2020.3中得到修复

支付宝捐赠
请使用支付宝扫一扫进行捐赠
微信捐赠
请使用微信扫一扫进行赞赏
有 0 篇文章